Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
'Authorization Code Mismatch'
#11
(05-26-2019, 01:28 AM)Lurker101 Wrote:
(05-26-2019, 01:07 AM)Shiny Star Wrote:
(05-26-2019, 12:12 AM)Lurker101 Wrote: Oh Kyng and most others here don't use the default theme so it gets neglected... I have given Kyng so many bug reports about it :P

Oiii. You know I actually use he default theme!

I haven’t encountered any issues but I automatically sign in.

Hey, I have been given so much crap by Kyng, Nilla, and others about using the default theme and how "no one uses it" <_<

I can't speak for Nilla, but I don't recall ever saying that, because it's not even true :P . Out of 186 registered users, 133 are on the default theme, and a further 8 are on the variant with larger text. (I don't know how many of those are *active*, but I suspect it's still the most-used theme even among people who have visited within the past week or month or whatever)
[Image: CJ_userbar.png]

Board Information and Policies
Affiliation | Coffee Credits | Member Ranks | Awards | Name Changes | Account Deletion
Personal Data Protection
| BBCode Reference

Lurker101 Wrote:I wouldn't be surprised if there was a Mega Blok movie planned but the pieces wouldn't fit together.

(Thanks to ObsessedwithBirds for the avatar and sig!)
My Awards
x1 x1 x2 x2 x5 x3 x1 x3 x6
My Items
Quote
#12
Sorry, but it's still not working right, and even when I would try to log in using Dark Energy (which you did state uses that same templates as the default theme). The ONLY way that I can log in is if I try to reply to a post as a guest. Otherwise, I just get taken back to that same error page. It's really tedious...
My Awards
My Items
Quote
#13
I know when I got it it showed me as logged in.
[Image: H4kDJkp.jpg]
My Awards
x1 x1 (2018) x1 (2017) x1 (2016)
My Items
F-Chan
Quote
#14
What browser are you using and are you using a computer or a mobile device?
[Image: images?q=tbn:ANd9GcThA1gowquN5v4r388-VQv...5iS5WvSi9s]
My Awards
x1 x1 x1 x1 (2016) x2 x1
My Items
Barry
Quote
#15
(05-26-2019, 02:50 AM)Digital Dictator Wrote: Sorry, but it's still not working right, and even when I would try to log in using Dark Energy (which you did state uses that same templates as the default theme). The ONLY way that I can log in is if I try to reply to a post as a guest. Otherwise, I just get taken back to that same error page. It's really tedious...
Wow, I'm sorry to hear it's still not working :( .

Though, if it's working consistently from the "No permissions" page, but not from the regular login, then that would suggest that perhaps it is a template issue after all. It would suggest that "error_no_permissions" is fine, but "header_welcomeblock_guest" is not.

This is the entire text of my "header_welcomeblock_guest" template:

"header_welcomeblock_guest template"

As you can see, this has the correct <input> tag immediately below the <form> tag. One thing I did notice, however, was that it has the 'action' attribute set to "{$mybb->settings['bburl']}/member.php" instead of "member.php". I don't see why this would be affecting anything (those should both be pointing to the same location), but I've changed it to just "member.php" anyway to see whether that will fix it. I'm not optimistic, but it's all I can see :-/ .

(05-26-2019, 02:52 AM)Megan Wrote: I know when I got it it showed me as logged in.

Yeah, when I got it on my phone, it logged me in correctly too. That would suggest that your problem is distinct from Digital Dictator's.
[Image: CJ_userbar.png]

Board Information and Policies
Affiliation | Coffee Credits | Member Ranks | Awards | Name Changes | Account Deletion
Personal Data Protection
| BBCode Reference

Lurker101 Wrote:I wouldn't be surprised if there was a Mega Blok movie planned but the pieces wouldn't fit together.

(Thanks to ObsessedwithBirds for the avatar and sig!)
My Awards
x1 x1 x2 x2 x5 x3 x1 x3 x6
My Items
[-] The following 1 user Likes Kyng's post:
  • Megan
Quote
#16
(05-26-2019, 10:11 AM)Kyng Wrote:
(05-26-2019, 02:50 AM)Digital Dictator Wrote: Sorry, but it's still not working right, and even when I would try to log in using Dark Energy (which you did state uses that same templates as the default theme). The ONLY way that I can log in is if I try to reply to a post as a guest. Otherwise, I just get taken back to that same error page. It's really tedious...
Wow, I'm sorry to hear it's still not working :( .

Though, if it's working consistently from the "No permissions" page, but not from the regular login, then that would suggest that perhaps it is a template issue after all. It would suggest that "error_no_permissions" is fine, but "header_welcomeblock_guest" is not.

This is the entire text of my "header_welcomeblock_guest" template:

"header_welcomeblock_guest template"

As you can see, this has the correct <input> tag immediately below the <form> tag. One thing I did notice, however, was that it has the 'action' attribute set to "{$mybb->settings['bburl']}/member.php" instead of "member.php". I don't see why this would be affecting anything (those should both be pointing to the same location), but I've changed it to just "member.php" anyway to see whether that will fix it. I'm not optimistic, but it's all I can see :-/ .
(05-26-2019, 02:52 AM)Megan Wrote: I know when I got it it showed me as logged in.

Yeah, when I got it on my phone, it logged me in correctly too. That would suggest that your problem is distinct from Digital Dictator's. 

Well for me it’s not really a problem, only does it if I accidentally either hit the button twice or if I’m on my computer where it automatically will log me in after I put in my login info. I don’t think it’s really anything with that one.
[Image: H4kDJkp.jpg]
My Awards
x1 x1 (2018) x1 (2017) x1 (2016)
My Items
F-Chan
Quote
#17
Well, I had another go at this on several different browsers (Chrome, Firefox, and Microsoft Edge), and each time, I was unable to replicate the error.

I also tried in Chrome with Javascript turned off. Once again, I was able to log in and out just fine.

If it's a cache issue, then I'd expect a hard refresh (CTRL + F5) to resolve it - although, if that's what it is, then I'd really want to know what's causing it to cache so aggressively.

Otherwise, I'm at a loss, unless an error can be found in the "header_welcomeblock_guest" template code I posted :-/ . If the issue hasn't been resolved by now, I'll go onto MyBB support and ask about it tomorrow.
[Image: CJ_userbar.png]

Board Information and Policies
Affiliation | Coffee Credits | Member Ranks | Awards | Name Changes | Account Deletion
Personal Data Protection
| BBCode Reference

Lurker101 Wrote:I wouldn't be surprised if there was a Mega Blok movie planned but the pieces wouldn't fit together.

(Thanks to ObsessedwithBirds for the avatar and sig!)
My Awards
x1 x1 x2 x2 x5 x3 x1 x3 x6
My Items
Quote
#18
And, since plugins can alter your templates, that should give you a few clues as to which might be causing these underlying issues. I learned a very important lesson on cutting down bloat as humanly possible.

I'm strictly a desktop user, and my browsers of choice are Firefox-based ones (e.g. Pale Moon, IceCat).
My Awards
My Items
Quote
#19
Doesn't look to me as though "header_welcomeblock_guest" has been modified by any plugins :-/ . I did take a look at the diff report, though, and I found that the last four table rows have been replaced by "{$loginform}" at some point. So, I've made that change now.

I'm a little more optimistic about this change, but obviously, I still can't make any guarantees.



UPDATE: I've downloaded Pale Moon, and been unable to replicate this issue with any version of the header_welcomeblock_guest template code.

For now, I've reverted this template to the original (since I'm pretty sure this won't screw up any plugins). This does mean we've lost the FontAwesome icons for now; however, that's a small price to pay if it means we have a login system that works correctly for everyone (and, in any case, I can just re-add them via CSS at some point :P ).

(Just a random stab in the dark: if reverting the template still hasn't solved it, then I wonder whether the browser is auto-filling this input field with a previous out-of-date value :-/ ?)
[Image: CJ_userbar.png]

Board Information and Policies
Affiliation | Coffee Credits | Member Ranks | Awards | Name Changes | Account Deletion
Personal Data Protection
| BBCode Reference

Lurker101 Wrote:I wouldn't be surprised if there was a Mega Blok movie planned but the pieces wouldn't fit together.

(Thanks to ObsessedwithBirds for the avatar and sig!)
My Awards
x1 x1 x2 x2 x5 x3 x1 x3 x6
My Items
Quote


Forum Jump:


Users browsing this thread: 1 Guest(s)