Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"This message is missing"
#21
Well, I finally have an update on this. It's taken a loooooong time to find out what the problem is; however, while @ Nilla and myself were setting up our new test board, we discovered what the issue was. 

It appears to be a conflict between the Mentions system and the text editor we use. If I disable mentions, then the issue goes away. Or, if I disable the text editor, then the issue goes away. But, having them both leads to "The message is missing" issues when you're using Source Mode by default. 

I have informed the developers behind both plugins. However, I don't know what the prospects of this being fixed are (both are volunteers, and the developer of the text editor isn't responsible for fixing issues with the Mentions system and vice versa). So, it may be that we have to face a choice of either: a) disabling the Mentions system, b) disabling the text editor, or c) living with "The message is missing" in Source Mode forever. I have no desire to disable mentions, and I also have no desire to remove the text editor (because that would mean going back to the default editor which comes with MyBB, which has annoying bugs of its own which IMO make it an even worse choice). So, for the time being, I'm keeping both and living with the issue. 

For now, the 'fix' is as it has been since September: go into your Profile Options, and untick "Put the editor in Source Mode by default" if it is ticked. If you have not already done this, then I strongly recommend you do so.
[Image: CJ_userbar.png]

Board Information and Policies
Affiliation | Coffee Credits | Member Ranks | Awards | Name Changes | Account Deletion
Personal Data Protection
| BBCode Reference

Lurker101 Wrote:I wouldn't be surprised if there was a Mega Blok movie planned but the pieces wouldn't fit together.

(Thanks to ObsessedwithBirds for the avatar and sig!)
My Awards
x1 x1 x2 x2 x5 x3 x1 x3 x6
My Items
#22
At least you can still use source mode; I've found you can use it so long as it isn't enabled by default. :P
[Image: tmatt00y.gif]
My Awards
x1 x1 (2018)
My Items
[-] The following 1 user Likes Oscar's post:
  • Kyng
#23
(02-08-2019, 02:27 AM)Oscar Wrote: At least you can still use source mode; I've found you can use it so long as it isn't enabled by default. :P

Yes, that's correct: it's fine when it's enabled manually for an individual post :)

I will concede that it is annoying to have to enable Source Mode manually on every individual post, and it'd be nice if it would work when just enabled by default, but I guess it is better than nothing.
[Image: CJ_userbar.png]

Board Information and Policies
Affiliation | Coffee Credits | Member Ranks | Awards | Name Changes | Account Deletion
Personal Data Protection
| BBCode Reference

Lurker101 Wrote:I wouldn't be surprised if there was a Mega Blok movie planned but the pieces wouldn't fit together.

(Thanks to ObsessedwithBirds for the avatar and sig!)
My Awards
x1 x1 x2 x2 x5 x3 x1 x3 x6
My Items
#24
This should be fixed now (albeit at the cost of losing the auto-complete box for mentions). For more details, please see this thread.

If you're still running into this problem, please let me know here :) .
[Image: CJ_userbar.png]

Board Information and Policies
Affiliation | Coffee Credits | Member Ranks | Awards | Name Changes | Account Deletion
Personal Data Protection
| BBCode Reference

Lurker101 Wrote:I wouldn't be surprised if there was a Mega Blok movie planned but the pieces wouldn't fit together.

(Thanks to ObsessedwithBirds for the avatar and sig!)
My Awards
x1 x1 x2 x2 x5 x3 x1 x3 x6
My Items


Forum Jump:


Users browsing this thread: 1 Guest(s)